10 funciones esenciales de Microsoft Excel para el análisis de datos

Microsoft Excel proporciona a los usuarios cientos de funciones y fórmulas diferentes para diferentes propósitos. Ya sea que necesite analizar sus finanzas personales o cualquier otro gran conjunto de datos, estos son los recursos que lo hacen fácil. Además, ahorra mucho tiempo y esfuerzo. Sin embargo, encontrar la función correcta para su conjunto de datos puede ser muy complicado.

Funciones y fórmulas de Microsoft Excel para el análisis de datos

Entonces, si tiene dificultades para encontrar la función de Excel adecuada para el análisis de datos, ha venido al lugar correcto. Aquí hay una lista de algunas funciones esenciales de Microsoft Excel que puede usar para el análisis de datos y así aumentar su productividad.

anotar: Para los no iniciados, las funciones mencionadas en este artículo deben agregarse en la barra de fórmulas de una hoja de cálculo de Excel que contiene datos o en la celda donde desea obtener el resultado.

Índice
  1. 1. CONCATENAR
  2. 2.LARGO
  3. 3. BUSCARV
  4. 4. ÍNDICE/CONVENIO
  5. 5. MINIFS/MAXIFS
  6. 6. PROMEDIO SI
  7. 7. CONTADORES
  8. 8. PRODUCTO RESUMEN
  9. 9. RECORTAR
  10. 10. ENCONTRAR/INVESTIGAR
  11. análisis de datos maestros

1. CONCATENAR

=CONCATENAR es una de las funciones más importantes para el análisis de datos porque te permite combinar texto, números, fechas, etc. varias celdas en una. La función es particularmente útil para combinar datos de diferentes celdas en una sola celda. Por ejemplo, es útil para crear parámetros de seguimiento para campañas de marketing, crear solicitudes de API, agregar texto a un formato de número y muchas otras cosas.

Funciones esenciales de Excel Análisis de datos 1

En el ejemplo anterior, quería el mes y las ventas juntos en una sola columna. Para eso, usé la fórmula =CONCATENER(A2, B2) en la celda C2 para obtener como resultado 700 de enero.

Fórmula: =CONCATENAR(celdas que desea combinar)

2.LARGO

=LEN es otra función útil para el análisis de datos que básicamente genera la cantidad de caracteres en una celda determinada. La función se puede utilizar principalmente cuando se crean etiquetas de título o descripciones que tienen un límite de caracteres. También puede ser útil cuando se trata de averiguar las diferencias entre los distintos identificadores únicos, que suelen ser bastante largos y no están en el orden correcto.

Lee También:   34 Mejores sitios y aplicaciones de compras como Wish para comprar en línea
Funciones esenciales de Excel Data Analysis 2

En el ejemplo anterior, quería contar la cantidad de visitas que obtenía cada mes. Para eso, usé la fórmula =LEN(C2) en la celda D2 para obtener 5 como resultado.

Fórmula: =LARGO(célula)

3. BUSCARV

=BUSCARV es probablemente una de las funciones más reconocibles para cualquier persona familiarizada con el análisis de datos. Puede usarlo para combinar datos de una tabla con un valor de entrada. La función ofrece dos modos de coincidencia: exacto y aproximado, que están controlados por el ámbito de búsqueda. Si establece el rango en FALSO, buscará una coincidencia exacta, pero si lo establece en VERDADERO, buscará una coincidencia aproximada.

Funciones esenciales de Excel Análisis de datos 3

En el ejemplo anterior, quería encontrar la cantidad de vistas en un mes determinado. Para eso, utilicé la fórmula =BUSCARV("Jun", A2:C13, 3) en la celda G4 y obtuve 74992 como resultado. Aquí "Jun" es el valor de búsqueda, A2:C13 es la tabla que busco "Jun" y 3 es el número de columna donde la fórmula encontrará las vistas correspondientes para junio.

El único inconveniente de usar esta función es que solo funciona con datos organizados en columnas, de ahí el nombre: búsqueda vertical. Entonces, si sus datos están organizados en filas, primero debe transponer filas a columnas.

Fórmula: =BUSCARV(valor_buscado, matriz_tabla, núm_índice_columna, [range_lookup])

4. ÍNDICE/CONVENIO

Al igual que la función BUSCARV, las funciones ÍNDICE y COINCIDIR son útiles para buscar datos específicos en función de un valor de entrada. ÍNDICE y COINCIDIR, cuando se usan juntos, pueden superar las limitaciones de VLOOKUP de dar resultados erróneos (si no tiene cuidado). Entonces, cuando combina estas dos funciones, pueden identificar la referencia de datos y buscar un valor en una matriz unidimensional. Esto devuelve las coordenadas de los datos como un número.

Funciones esenciales de Excel Análisis de datos 4

En el ejemplo anterior, quería encontrar la cantidad de vistas en enero. Para esto, utilicé la fórmula =ÍNDICE(A2:C13, COINCIDIR("Jan", A2:A13,0), 3). Aquí A2:C13 es la columna de datos que quiero que devuelva la fórmula, "Jan" es el valor que quiero hacer coincidir, A2:A13 es la columna en la que la fórmula encontrará "Jan" y el 0 significa que quiero que la fórmula encontrar una coincidencia exacta para el valor.

Lee También:   ¿Rite Aid acepta giros postales? (Comisiones, límites, seguimiento, etc.)

Si desea encontrar una coincidencia aproximada, deberá reemplazar el 0 con 1 o -1. Entonces, 1 encontrará el valor más grande menor o igual que el valor de búsqueda y -1 encontrará el valor más pequeño menor o igual que el valor de búsqueda. Tenga en cuenta que si no usa 0, 1 o -1, la fórmula usará 1, incluso.

Funciones esenciales de Excel Data Analysis 5

Ahora, si no desea codificar el nombre del mes, puede reemplazarlo con el número de teléfono móvil. Entonces podemos reemplazar "Jan" en la fórmula mencionada anteriormente con F3 o A2 para obtener el mismo resultado.

Fórmula: =ÍNDICE(columna de los datos que desea devolver, COINCIDIR (punto de datos común que está tratando de hacer coincidir, columna de la otra fuente de datos que tiene el punto de datos común, 0))

5. MINIFS/MAXIFS

=MINIFS y =MAXIFS son muy similares a las funciones =MIN y =MAX, excepto que le permiten tomar el conjunto de valores mínimos/máximos y también relacionarlos con criterios específicos. Básicamente, la función busca valores mínimos/máximos y los compara con los criterios de entrada.

Funciones esenciales del análisis de datos de Excel 7

En el ejemplo anterior, quería encontrar las calificaciones mínimas según el género del estudiante. Para eso usé la fórmula =MINIFS(C2:C10,B2:B10, "M") y obtuve el resultado 27. Aquí C2:C10 es la columna en la que la fórmula buscará los puntajes, B2:B10 es una columna en el que la fórmula buscará criterio (género) y "M" es el criterio.

Funciones esenciales de Excel Análisis de datos 6

De manera similar, para las puntuaciones máximas, utilicé la fórmula =MAXIFS(C2:C10, B2:B10, "M") y obtuve el resultado 100.

Fórmula para MINIFS: =MINIFS(rango_mínimo, rango_de_criterios1, criterio1,…)

Fórmula para MAXIFS: =MÁX.SI(max_range, criterio_rango1, criterio1,…)

6. PROMEDIO SI

La función =AVERAGEIFS le permite encontrar un promedio para un conjunto de datos determinado en función de uno o más criterios. Al usar esta función, debe tener en cuenta que cada criterio y cada rango promedio pueden ser diferentes. Sin embargo, en la función =PROMEDIO.SI, el rango de criterios y el rango de suma deben tener el mismo rango de tamaño. ¿Notas la diferencia entre singular y plural entre estas funciones? Bueno, aquí es donde hay que tener cuidado.

Lee También:   18 formas fáciles de comprar carne más barata (cerca de mí)
Funciones esenciales de Excel Análisis de datos 8

En este ejemplo, quería encontrar el puntaje promedio basado en el género de los estudiantes. Para eso, usé la fórmula =PROMEDIO.SI.CONJUNTO(C2:C10, B2:B10, "M") y obtuve 56.8 como resultado. Aquí, C2:C10 es el rango en el que la fórmula buscará la media, B2:B10 es el rango del criterio y "M" es el criterio.

Fórmula: =PROMEDIO(rango_promedio, rango_criterio1, criterio1,…)

7. CONTADORES

Ahora, si desea contar la cantidad de instancias en las que un conjunto de datos cumple con criterios específicos, debe usar la función = COUNTIFS. Esta función le permite agregar criterios ilimitados a su consulta, lo que la convierte en la forma más fácil de encontrar el número según sus criterios de entrada.

Análisis de datos de funciones esenciales de Excel 9

En este ejemplo, quería encontrar el número de estudiantes masculinos o femeninos que aprobaron el grado (es decir, >= 40). Para esto usé la fórmula =CONT.SE(B2:B10, "M", C2:C10, ">=40"). Aquí, B2:B10 es el rango en el que la fórmula buscará el primer criterio (género), "M" es el primer criterio, C2:C10 es el rango en el que la fórmula buscará el segundo criterio (grados), y ">= 40" es el segundo criterio.

Fórmula: =CONTAR.SI(criterio_rango1, criterio1,…)

8. PRODUCTO RESUMEN

La función =SUMPRODUCT ayuda a multiplicar rangos o matrices y luego devuelve la suma de los productos. Esta es una función muy versátil y se puede usar para contar y sumar arreglos como CONTAR.SI.SI.CONJUNTO o SUMAR.SI.CONJUNTO, pero con mayor flexibilidad. También puede utilizar otras funciones en SUMPRODUCT para ampliar aún más su funcionalidad.

10 funciones esenciales del análisis de datos de Excel

En este ejemplo, quería encontrar la suma total de todos los productos vendidos. Para esto, usé la fórmula =SUMAPRODUCTO(B2:B8, C2:C8). Aquí, B2:B8 es la primera matriz (la cantidad de productos vendidos) y C2:C8 es la segunda matriz (el precio de cada producto). Luego, la fórmula multiplica la cantidad de cada producto vendido por su precio y lo suma todo para obtener las ventas totales.

Fórmula: =SUMAPRODUCTO(matriz1, [array2], [array3],…)

9. RECORTAR

La función =TRIM es particularmente útil cuando se trabaja con un conjunto de datos que tiene muchos espacios o caracteres no deseados. La función le permite eliminar fácilmente estos espacios o caracteres de sus datos, lo que le permite obtener resultados precisos al usar otras funciones.

Análisis de datos de funciones esenciales de Excel 11

En este ejemplo, quería eliminar todos los espacios adicionales entre las palabras Mouse y pad en A7. Para esto usé la fórmula =TRIM(A7).

Análisis de datos de funciones esenciales de Excel 12

La fórmula simplemente eliminó los espacios adicionales y entregó el resultado de Mouse Pad con un solo espacio.

Fórmula: =CORTAR(texto)

10. ENCONTRAR/INVESTIGAR

Para colmo, las funciones BUSCAR/BUSCAR te ayudarán a aislar texto específico en un conjunto de datos. Las dos funciones son bastante similares en lo que hacen, excepto por una gran diferencia: la función =ENCONTRAR solo devuelve coincidencias que distinguen entre mayúsculas y minúsculas. Mientras tanto, la función =SEARCH no tiene tales limitaciones. Estas funciones son particularmente útiles cuando se buscan anomalías o identificadores únicos.

Funciones esenciales del análisis de datos de Excel 13

En este ejemplo, quería encontrar la cantidad de veces que 'Gui' apareció en Guiding Tech, para lo cual usé la fórmula = ENCONTRAR (A2, B2) que devolvió el resultado 1. Ahora, si quisiera encontrar la cantidad de veces que 'gui' apareció en Guiding Tech, debo usar la fórmula =BUSCAR ya que no distingue entre mayúsculas y minúsculas.

Fórmula de búsqueda: = encontrar (buscar_texto, en_texto, [start_num])

Fórmula de búsqueda: =BUSCAR(buscar_texto, en_texto, [start_num])

análisis de datos maestros

Estas funciones esenciales de Microsoft Excel ciertamente lo ayudarán con el análisis de datos, pero esta lista solo rasca la punta del iceberg. Excel también incluye varias otras funciones avanzadas para obtener resultados específicos. Si desea saber más sobre estas características, háganoslo saber en la sección de comentarios a continuación.

Próximo : Si desea usar Excel de manera más eficiente, consulte el siguiente artículo para conocer algunos atajos de navegación útiles de Excel que debe conocer.

TE PUEDE INTERESAR

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Subir